以管理员身份

进入cmd命令行

进入apache的安装目录C:\apache\bin\

执行httpd.exe -k install 命令

from: csdn

composer 安装包时包405 Downloading (failed) Failed to download fideloper/proxy from dist: The “https://files.phpcomposer.com/files/fideloper/TrustedProxy/cf8a0ca4b85659b9557e206c90110a6a4dba980a.zip” file could not be downloaded (HTTP/1.1 405 Not Allowed) Now trying to download from source 如上可 在命令后加–prefer-source

  • –prefer-source: 下载包的方式有两种: source 和 dist。对于稳定版本 composer 将默认使用 dist方式。而 source 表示版本控制源 。如果 --prefer-source 是被启用的,composer 将从 source 安装(如果有的话)。如果想要使用一个 bugfix 到你的项目,这是非常有用的。并且可以直接从本地的版本库直接获取依赖关系。

from: composer docs

composer config -g repo.packagist composer https://packagist.phpcomposer.com

from: scdn

–给root授权

grant all privileges on *.* to root@”%” identified by ‘abc’ with grant option;

–使得设置立刻生效

flush privileges;

–root 是用户名 abc是密码

from csdn